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General
MMiinniimmaall  rreeqquuiirreedd  ccoonnffiigguurraattiioonn
Operating system

• Windows 95 or higher
• Windows NT 4 Service Pack 3 or higher

Processor
All ; A more powerful processor will speed up loading and merging operations of
large files.

Memory
16 Mb ; Performances are better with more memory.

Graphical resolution
640*480 16 colors.

Communication port
1 free COM port.

Version problem with Comctl32.dll file

This problem concern the first version of Windows 95, it doesn’t occur on Windows version
superior or equal to OSR B version of Windows 95 (Windows 98 and Windows NT aren’t
affected).

To launch ASTPWin, you must have on your system the 4.70 version for the Windows DLL
COMCTL32.DLL. Actually with the first version of Windows 95, released in October 95,
there’s a bug which can hang up the computer.
To install the correct version of this file, you must download the Comctl32.exe file ,
available for free on the Microsoft web site and decompress it.
Then, restart the computer in DOS mode and replace the file with the same name
(COMCTL32.DLL) which is on the system directory of Windows (C:\WINDOWS\SYSTEM
in most cases).

Note that ASTPWin won’t run if the version of this file isn’t correct.
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PPrreesseennttaattiioonn
ASTPWin allows data acquisition on CIMEL Electronique instruments.

The main ASTPWin window is composed of several parts :

It’s possible to access all the ASTPWin functions with the main menu (1).

The part (2) contains the icon shortcuts. Each icon accelerate the access to one particular
function. To know the signification of each image, let the mouse cursor a few seconds over it.

The part (3) allows to see the acquisition progression. This part is only visible if the
communication port has been opened.

The list of events (or scenarios) currently edited is indexed in the list view (4). The selected
scenario detail is in text chart (5). This chart is only visible if the measurement details
visualization is activated.
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Data acquisition
HHaarrddwwaarree  ccoonnffiigguurraattiioonn
ASTPWin need to know the link type between the PC and the instrument, the communication
port (from COM1 to COM4) and the transmission speed (1200 or 9600 bauds). To specify
you configuration, select the menu « Tools->General Setup » in the principal menu
and click on the « Communication » sheet.

Link kind choice

For a local link with a serial port, choose Serial link, for a MODEM link, choose MODEM.
By selecting MODEM, you will have to setup the MODEM initialization string, and the
number of ring before the MODEM pick up to answer the call.

Communication port choice

You must indicate the communication port number used for the acquisition (from COM1 to
COM4).

Transmission speed

The speed (in bauds) is the speed used for the transmission. That option is generally 1200
Bauds. At this time, only few  instruments can handle 9600 Bauds speed rate. Standard
instruments are running at 1200 bauds.
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AAccqquuiissiittiioonn  llaauunncchh
Connecting to the communication port

To activate the link with the serial port, select the item « Tools->Connect /
Disconnect » in the main menu or click on the following shortcut icon :

Link connection ON / OFF

The acquisition progression visualization should appear :

The software is now waiting for an instrument transmission.

If the dialog don’t appear, the communication port can’t be opened :
• Verify the communication port number.
• Verify if the communication port isn’t already used by Windows or by another

application.
• Some portable computer doesn’t have COM1 communication port. Choose another

communication port.

Acquisition launch

The acquisition start when the instrument begin to send data :
• Connect the instrument to the chosen communication port
• Select the PC scenario on the instrument (see the instrument documentation for

much details, by default : MAN / SEL / PC / GO ).

The data transmission LED (4) becomes green as soon as data from the instrument come :

This panel gives some information about the status of the current acquisition. The transmitted
memory (1) is the percentage of  memory uploaded in the PC. The number of characters
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received (2), the amount of time from the transmission starts (3) and the average acquisition
speed in characters per second (5) are given for information. The graphic (6) shows the last 30
seconds of transmission, it allows to report the stability and the cuttings during the data
transmission.

Acquisition end

The acquisition stops automatically, but can be terminated by a user intervention :

Stop transmission

The data transfer end if one of these conditions is done :
• The instrument memory is fully transmitted (Detection : the last received scenario was

already received at the start of the transmission)
• Two consecutive empty events were received and the related stop option was activated.
• The connection between the PC and the instrument was broken (no data received during

several seconds)
• The connection between the PC and the instrument is too bad (less than two characters per

seconds transmitted during the 30 last seconds)
• The transfer was interrupted by the user

Then, the scenarios list is refreshed.
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AAddvvaanncceedd  ooppttiioonnss
Automatic data storage

It’s possible to create automatically after every transfer
• The .K7 file of the acquisition
• ASCII files organized by period

To parameter the automatic data storage, choose in the menu « Tools->General
setup » the tab « Data ».

By activating the automatic recording (1), K7 files will be saved automatically in the K7
directory (2).
The K7 file name is automatically created with the PC date at the time of the end of the
transmission. The file name is MMDDhhmm.K7 (MM = Acquisition month, DD =
Acquisition day, hh = Acquisition hour and mm = Acquisition minute). To activate this option
permit to configure the ASCII files creation.

The option « Create ASCII files » validate the text files creation (3).

The data in text files can be organized in several ways (4):
• No period (None)

The files are created with the same K7 file name (MMDDhhmm.EXT).
• Hourly period
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The data are gathered hour by hour. The files are named hhDDMMYYYY.EXT.
• Daily period

The data are gathered day by day. The files are named DDMMYYYY.EXT.
• Monthly period

The data are gathered month by month. The files are named MMYYYY.EXT.
• Yearly period

The data are gathered year by year. The files are named YYYY.EXT.
• Infinite period

The data are gathered in the same file. The file name is equal to the base name.

Attention: Larger is the period, longer takes the treatment time for adding data.

The base name (5) is the optional prefix that is added before the text file name. For example if
the base name is "PARIS_" and the period is monthly, the file name for June 98 will be
PARIS_0698.EXT (EXT us the ASCII file extension).

The option « Optimize transmissions » (6) allows to stops the transmission when the
software detects a scenario already transmitted in previous communications.

Automatic connection at the start

It’s possible to connect (to open) automatically to the communication port at every launch of
ASTPWin. That option is convenient when occurs a power failure and you want launch
automatically ASTPWin is reception mode at the computer start.
To activate that option, choose the menu « Tools->General setup » tab
« communication » and check « Automatic connection at the start ».

Stop the transmission after two empty events

Activate this option in order to optimize the transmission. The PC stops the acquisition when
it detects two consecutive empty events (0xFF type). In fact, when two empty events are
produced, the rest of the instrument memory should not contain data anymore.
To activate that option, choose the menu « Tools->General setup »,
« communication » tab and check « Stop the connection after two empty
events ».
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TTrraannssmmiissssiioonn  ssttaattiissttiiccss
ASTPWin can display statistics about the transmission done during the current session. These
statistics are useful for example, if the user isn’t physically present during automated
transmission.

Writing transmissions report

That option create a little log file about the communications. Each transmission add one line
to this file. The file name is « Transmission.Log », it’s stored in the root directory of
ASTPWin. This file is never deleted, the data are always appended to it. That’s why the user
should erase periodically this file if that option is activated.
To activate that option, choose the menu « Tools->General setup » , « Misc. » tab
and check « Write transmissions report ».

Transmissions history visualization

To see the history, choose the menu « Tools->Transmission history ».
That screen shows the list of transmissions done during the current session.

The number of transmission (1) is the amount of communication done from the start of
ASTPWin.

Columns description (2) :
• Date / Time

Date and time when the transmission started.
• Duration

Duration of each transmission.
• Errors

Number of errors during each transmission. It’s an indication of the transmission quality.
• End Trans.

Show how the transmission ended :
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OK : It normally ends.
Canceled : The transmission was canceled by the user.
Timeout : There was no data during about 10 seconds. The software has ended the

connection.
Bad trans : The connection was so bad that the program terminate the transmission.

• Scenarios
Amount of scenarios (events) transmitted.

• Bytes
Amount of bytes transmitted during the communication.

• Speed
Compute a transmission speed (in characters / sec.).

The « Save » button (3) saves the list in a simple ASCII file.
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Data visualization
SScceennaarriiooss  lliisstt
The scenarios list shows the content of the currently edited K7 file :

It’s an information panel including some general information : The complete file name (1),
it’s size (2) and the number of  scenarios (3) contained and the CIMEL instrument name (4).
After that comes the scenarios detail. That list (5) is composed of several columns :

• Type Scenario type (short name or extension)
• Date / Time Time when the scenario starts
• Size Size of the event in bytes
• Data Show  the digital counts

Note that when a transmission occurs, you’re not allowed to use that list.
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Events sorting

You can sort that list by your criterion by clicking on the title of the column.

A first click sort the scenarios in increasing order:

A second click sort the scenarios in decreasing order :

Scenario type

The scenario type condition the ASCII file name extension. Direct sun data (SUN type) will
create file with a .SUN extension.

If the scenario isn’t recognized by the software, the type is ? ? ?. Please contact CIMEL
Electronique to add the new scenario in the program.
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SScceennaarriiooss  ssuupppprreessssiioonn
It’s possible to suppress bad or uninteresting scenarios.

Select scenarios to remove , click on the right mouse button and select « Remove ». It’s also
possible to suppress the events with the main menu « Measurement->Delete
measurements ».

The selected scenarios are definitely removed from the K7 file.

MMeeaassuurreemmeenntt  ddeettaaiillss

To know the details of one event, choose in the main
menu « Measurement -> Measurement
details ».

A new window appears and shows the details of one
measurement. Each symbol correspond to a data type
family :

Date
Time
Filter number
Temperature
System data
Battery
Angle
Physical data (DC)
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AAddvvaanncceedd  ooppttiioonnss
Display empty scenarios (.INI)

It’s possible to hide or to show the empty scenario (0xFF Type) in the scenario list. By
default, this scenario type is hidden because it don’t bring interesting information.
To activate that option, select the menu « Tools->General setup », « misc. » tab and
check « Display empty scenarios (.INI)»

Display scenarios with errors

It’s possible to hide or to show the scenarios with errors (transmission error, bad checksum,
unknown scenario or impossible to decode…) in the scenario list. By default, these scenario
types are displayed.
To activate that option, choose the menu « Tools->General setup », tab « misc. »
tab and check « Display scenarios with errors ».

DDaattaa  pprroocceessssiinngg  aanndd  PPlluugg--IInnss
ASTPWin Software organization

ASTPWin is an open software which manage particular treatment adding :

ASTPWin
Data acquisition, data visualization

ASCII exportation, .K7 saving
Plug-Ins management

Pl
ug

-In
s M

od
ul

es Special acquisitions (radiometer…)

Data processing (Bouguer calibration…)

Graphical visualizations

Various exportations (NASA format...)
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How the Plug-Ins work

Physically, a plug-in is a .DLL file with optionally some others data files. When it’s placed in
the plug-in directory, it’s automatically added in the ASTPWin interface (typically in the
« Processing » menu) when the application starts :

Plug-Ins directory

You must indicate in what directory the plug-ins are stored.
To modify that directory, select the menu « Tools->General setup »,  « misc. » tab
and give the full path of that directory « Plug-ins directory ».
If that directory contains valid .DLL files for ASTPWin, the new processing will be added
ASTPWin at its next start (you must restart ASTPWin for chances to take effect).
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K7 files management
GGeenneerraalliittiieess
What’s a .K7 file ?

A .K7 file is originally an image of the inquired instrument memory. It’s size is 32kb, exactly
the size of the classical CIMEL Electronique instrument memory.
The new extensions allows to overtake that size and the .K7 files produced by ASTPWin can
do more than 32kb.

Importance of K7 files in relation to ASCII files

A K7 file can produce ASCII files, but the inverse isn’t true. It’s very important to keep the
K7 file rather than the ASCII files.

The K7 file contains :
• Instrument parameters (at the acquisition time)
• The scenarios that are correctly decoded
• The bad or partially transmitted scenarios (except for merged files)

If a scenario isn’t well decoded (due to a software problem), it’s possible to correct the bug
from the K7 file. If the use remove the K7 file, it’s impossible to go back.
Besides ASTPWin plug-ins are exclusively using K7 file format.

ASTP for DOS compatibility

The compatibility between ASTPWin and ASTP for DOS is total and in both directions :
• ASTP for DOS can use ASTPWin files.
• ASTPWin can use ASTP for DOS files.
There’s a limitation with files larger than 32kb that aren’t supported by ASTP for DOS (it
occurs for merged K7 files for example).

OOppeenniinngg  aanndd  ssaavviinngg  ffiilleess
The K7 file opening can be done in the main menu « File->Open… » or by clicking on the
shortcut icon :

Open a K7 file
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To write the currently edited file, select the menu « File->Save » or click on the shortcut
icon :

Save the K7 file

It’s possible to change the currently edited file name by selecting the menu « File->Save
as… »

SSeevveerraall  KK77  ffiillee  mmeerrggiinngg
You can merge several file together. That action is very useful to pack several days together
to process it all of a sudden. It’s possible to create a K7 file that contains the scenarios of
several K7 files.
Doubloons and scenarios with transmission errors are eliminated.
The file size can do more than the traditional 32kb that’s why it’s size is adjusted at it
minimum.

To merge the files, select in the menu « File->Merge K7 files » :

The K7 files source directory (1) specify where the K7 files are stored. All these files will be
used for the merging and will produced a huge K7 file.
It’s possible to add all the scenarios (Complete merging) (2) or to eliminate the scenarios
which aren’t included between the two dates (Between two dates merging) (3).
The fusion progress shows the merging progression, this process can be long and depends of
the computer power and the amount of files to merge.
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ASCII Exportation
To use the data in other applications and programs, it's simpler to convert the files in text files
which are readable by all the programs.

AASSCCIIII  eexxppoorrttaattiioonn  SSEETTUUPP
To configure the ASCII file format, go to the menu « Tools->General Setup » and
select the tab « ASCII Format »

The dates can be displayed with four or two digits (For example 2001 or 01), tick the slot (1)
to display the dates with all digits, on four numbers.

You are allowed to add quotation marks (") between the dates and the times. That option (2)
can be useful with some software for automatic dates recognition.

The option " Dates and times with not significant zeros " (3) allows to display the dates with a
fixed size format. To take an example, the 1st January 1998 is displayed 01/01/98 instead of
1/1/98.

It's possible to add a description header describing each column at the beginning of the ASCII
files. Select the box (4) to add it, here is an example of a file with this king of header :
Date,Time,Sun0,Sun1,Sun2,Sun3,Sun4,Sun5,Sun6,Sun7,Temp
06/03/1999,13:33:40,56,65,29,1,0,70,2,3,28.7
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06/03/1999,13:33:29,57,66,30,1,0,71,2,3,28.7
…

Each separator can be modified (5) to create files compliant to your recipient software.

The selection test line (6) shows quickly the format that will be used in the ASCII files.

CCuurrrreenntt  ffiillee  eexxppoorrttaattiioonn
To export the currently edited .K7 file, select in the main menu « Measurement->Save
ASCII files » or click on the shortcut icon :

Save the ASCII files

The ASCII files are created in the same directory of the K7 file but have a different extension.
Each extension corresponds to a different measurement :

PP1 Principal Plane
ALM Almucantar
RDR Direct radiance status
STA Instrument status
PPP Polarized principal plane
SUN Direct sun measurement
NSU Direct sun measurement triplet
SKY Sky measurement
SKX Sky measurement (Max)
CAX Calibration sky measurement (Max)
NSK Sky measurement triplet
SSK Mixed sun and sky triplet measurement
BLK Black measurement
RAD Filter / mirror radiometer measurement
R2M Filter / mirror radiometer measurement
R4M Radiometer measurement
R6M Radiometer measurement  (6 filters)
RBK Filter / mirror / black radiometer measurement
AUR Halo (aureole) measurement
CON Cone measurement
GND Ground measurement
CLL Calibration radiance measurement
LUM Radiance measurement
CRS Sun Cross
CRK Sky Cross

(this chart is only given for information and may not be complete)
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SSeevveerraall  KK77  ffiilleess  ccoonnvveerrssiioonn  iinn  AASSCCIIII
It possible to convert several K7 files (raw or merged) in ASCII text files.
To choose the files to convert, select the menu « File->Convert in ASCII… ».

The files list to convert (1) can be modified by adding files (2) or by removing selected files
items (3).

Indicate the directory where will be stored the ASCII files (4).
The ASCII files are sorted in chronological order and the doubloons are eliminated.

The text files data can be organized in different ways (5):
• No period

Created files have the same name of the K7 file, only the file extension change.
• Hourly period

Data are gathered hour by hour. Files are named hhDDMMYYYY.EXT.
• Daily period

Data are gathered day by day. Files are named DDMMYYYY.EXT.
• Monthly period

Data are gathered month by month. Files are named MMYYYY.EXT.
• Yearly period

Data are gathered year by year. Files are named YYYY.EXT.
• Infinite period
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Data are gathered in the same file. The file name is the base name with the specific ASCII
file extension.

Attention: Bigger is the period, longer is the computation time when adding data.

The base name (6) is an optional prefix that ASTP adds before the text file name. E.g. if the
base name is "PARIS_" and you choose a Monthly period, for the month of June 99, the
filename will be PARIS_0698.EXT (EXT is the extension of the ASCII file)
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Tools
PPaarraammeetteerrss  eeddiittiioonn
At the beginning of each transmission are transmitted the instruments EEPROM parameters
(Identification, position, gains…). You can visualize and modify (carefully!) these parameters
by selecting the menu « Tools->Parameters edition » :

It's possible to save the parameters in a text file (1) or to print them (2).
Each parameter can be edited by double clicking on it. Warning, the old parameters will be
lost if the modified K7 file is saved.
The name of the parameter is in the first column (3), then come the value of this parameter (4)
and the last column describe the parameter (5).

The instrument parameters definition is stored in a .PAR file. If ASTPWin didn't find the file,
an error message will be displayed « unable to load the parameter description file ». If  the
acquisition seems to be a good one, contact CIMEL Electronique to obtain a ASTPWin
update (go to the CIMEL Web : www.cimel.fr).

http://www.cimel.fr/
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